Jump to content

Dziwny problem z Chord Mojo 2


Raymont

Recommended Posts

Cześć,

 

Od kilku dni mam nowiuśkiego Mojo 2. Spinam go głównie z telefonem Samsung Galaxy S21 FE po kablu USB-C. Wcześniej nie zwróciłem na to uwagi (instrukcja do Mojo i te kolorowe kule zaczynają być w miarę intuicyjne dopiero po pewnym czasie użytkowania i przestudiowaniu instrukcji).

 

Otóż wg instrukcji i opisów nawet na tym forum - jak odtwarzam plik (np. flac) 44,1 kHz - to kula "power" powinna się świecić na czerwono, jak odtwarzany/dekodowany plik ma 48 kHz - na pomarańczowo, 96 kHz - na zielono, 192 kHz - na ciemnoniebiesko itd.

 

Tymczasem u mnie jest coś dziwnego, bo mam na telefonie zainstalowaną dosyć popularną i powszechną apkę do odtwarzania gęstych plików - czyli Pulsar. Jak odtwarzam pliki 44,1 kHz (pliki pewne, z hdtracks, zarówno sama aplikacja Pulsar, jak i np. foobar2000 na komputerze pokazują, że to plik 44,1 kHz) - to Mojo świeci na pomarańczowo (jak przy odtwarzaniu 48 kHz). Tak jest z dowolnym plikiem 44,1 kHz. Teraz jak włączam album we flac 24bit 192 kHz - to jest niby ok. Mojo świeci na ciemnoniebiesko. Ale jak włączę inny album (pliki 96 kHz. Album również w pełni legitny, pewne pliki, Pulsar pokazuje że to 96 kHz, foobar2000 również) - to zamiast na zielono.. Mojo zaświeca kulę na ciemnoniebiesko, identycznie jak przy pliku 192 kHz :(

 

A teraz coś, co już totalnie mnie rozłożyło na łopatki. Otóż byłem przekonany, że po wpięciu takiego Mojo po USB, w całości on przejmuje dekodowanie plików i odpowiednie wzmacnianie sygnału + przesył na słuchawki - a taka aplikacja na androidzie do odtwarzania muzyki typu Pulsar, VLC Player ma wtórne znaczenie, bo tylko "zapodaje" pliki do Mojo... Tymczasem jak przy wpiętym Mojo odtwarzam ww. pliki w aplikacji VLC Player, a nie Pulsar... to Mojo pokazuje mi cały czas kolor "żółty" (nawet jak odtwarzany jest album 192 kHz)...

 

W Mojo kompletnie nic nie było ruszane/przestawiane. Nie dotykałem zupełnie equalizera. W pełni naładowany, restartowany kilka razy - objaw jest cały czas jak powyżej. Po wpięciu go do laptopa z Windowsem 10 - Windows wykrywa Mojo itd, ale jak odtwarzam te same pliki z komputera na windowsowym VLC Playerze - zachowanie jest identyczne. Wszystkie pliki Mojo "widzi" jako 48 kHz, bo kula power świeci się na pomarańczowo... Czy ktoś zetknął się może z czymś takim?

 

 

 

Edited by Raymont
Link to comment
Share on other sites

Wygląda że nie masz połączenia bitperfect tylko zanim mojo dostanie dane to są one resamplowane przez systemy operacyjne/programy. Nie znam tego Pulsara ale bitperfect na androidzie można uruchomić np przez Usb Audio Player Pro i HiBy Music. 

 

Pod windosem trzeba używać Wasapi lub Asio aby uzyskać bitperfect bez tego windows wszystko kaszani resamplując. Zainstaluj sterowniki ze strony chorda i w ustawieniach wybranego odtwarzacza muzyki wybierz urządzenie: Wasapi Chord Async USB 44-768khz.

  • Like 1
Link to comment
Share on other sites

39 minut temu, Spawn napisał(a):

Wygląda że nie masz połączenia bitperfect tylko zanim mojo dostanie dane to są one resamplowane przez systemy operacyjne/programy. Nie znam tego Pulsara ale bitperfect na androidzie można uruchomić np przez Usb Audio Player Pro i HiBy Music. 

 

 

Wielkie dzięki :) Kupiłem ten USB Audio Player Pro, zainstalowałem na swoim telefonie i teraz wszystko zachowuje się poprawnie. A już się zaczynałem obawiać, że to coś z Mojo nie tak... Szkoda, że Android przy połączeniu USB OTG nie informuje że połączenie nie jest bitperfect i że coś może być nie tak...

Link to comment
Share on other sites

15 minut temu, Raymont napisał(a):

 

Wielkie dzięki :) Kupiłem ten USB Audio Player Pro, zainstalowałem na swoim telefonie i teraz wszystko zachowuje się poprawnie. A już się zaczynałem obawiać, że to coś z Mojo nie tak... Szkoda, że Android przy połączeniu USB OTG nie informuje że połączenie nie jest bitperfect i że coś może być nie tak...

 

Android wszystko resampluje bo tak ma zbudowaną warstwę audio. Obchodzą to tylko niektóre apki posiadające swoje sterowniki.

Link to comment
Share on other sites

Raz jeszcze dzięki, bo trafiłeś w sedno idealnie.

Upewnię się tylko jeszcze. Skoro po instalacji ww. USB Audio Player Pro, Mojo prezentuje dekodowane pliki poprawnie i całość wygląda/brzmi ok, to w ustawieniach samego Androida nic już nie muszę zmieniać/ustawiać? Wszystko załatwia już samoczynnie apka?

Edited by Raymont
Link to comment
Share on other sites

W UAPP wchodzisz w Settings, następnie Internal audio driver i tam powinieneś mieć odznaczone HiRes Direct driver, a nie Original Android driver.

Link to comment
Share on other sites

28 minut temu, Elhaz_77 napisał(a):

W UAPP wchodzisz w Settings, następnie Internal audio driver i tam powinieneś mieć odznaczone HiRes Direct driver, a nie Original Android driver.

 

Dzięki. Rozumiem że chodziło Ci nie o "odznaczone", tylko właśnie zaznaczone "HiRes Direct driver", zamiast "Original Android driver"?

Link to comment
Share on other sites

1 minutę temu, Raymont napisał(a):

 

Dzięki. Rozumiem że chodziło Ci nie o "odznaczone", tylko właśnie zaznaczone "HiRes Direct driver", zamiast "Original Android driver"?

Tak, ptaszek ma być przy "HiRes Direct driver" :)

Link to comment
Share on other sites

Ok, dziękuję. Sorry, że jeszcze drążę temat - ale zauważyłem jeszcze jedną opcję w UAPP, która może mieć tu znaczenie w kontekście tego o czym piszecie (połączenie bit perfect). W tej apcje, w Settings i później "USB Audio" jest opcja "Bit perfect mode". Z tego co piszecie jeśli jest ta opcja włączona - nic nie dotyka pliku idącego do zewnętrznego DAC. Jak tam wchodzę - to opcja jest wyłączona... Rozumiem, że też lepiej są włączyć?

Link to comment
Share on other sites

2 minuty temu, Raymont napisał(a):

Ok, dziękuję. Sorry, że jeszcze drążę temat - ale zauważyłem jeszcze jedną opcję w UAPP, która może mieć tu znaczenie w kontekście tego o czym piszecie (połączenie bit perfect). W tej apcje, w Settings i później "USB Audio" jest opcja "Bit perfect mode". Z tego co piszecie jeśli jest ta opcja włączona - nic nie dotyka pliku idącego do zewnętrznego DAC. Jak tam wchodzę - to opcja jest wyłączona... Rozumiem, że też lepiej są włączyć?

Tak, włącz ją, ustawiając na opcji On albo When possible

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Register to have access to community resources. Forum rules Terms of Use and privacy anc cookies policy Privacy Policy