Jump to content
zOrg

Problem - ES100 nie działa jako USB DAC pod Linuxem

Recommended Posts

Hej,

 

mam następujący problem z moim ES100.

 

po podłączeniu do laptopa system (Ubuntu 18.04 LTS) wykrywa go bez problemu, natomiast przy odtwarzaniu nie wydobywa się żaden dźwięk 😧 ( a pasek dzwięku "skacze", jakby odtwarzał muzykę)

 

dioda miga na przemian czerwono i zielono - tak samo miga , jak go podłączę po Win '10, a wtedy działa bez problemu jako USB DAC.

 

 

Może któryś z Kolegów Linuxiarzy, ma jakiś pomysł, co z tym zrobić?

 

 

Share this post


Link to post
Share on other sites

Alsamixergui sobie zainstaluj i zobacz czy nie masz czegoś wyciszonego i pavucontroll.

Share this post


Link to post
Share on other sites
4 godziny temu, hibi napisał:

Alsamixergui sobie zainstaluj i zobacz czy nie masz czegoś wyciszonego i pavucontroll.

 

zainstalowane

 

pojawia się tylko USB Mixer i można zmieniać niby głośność PCM i nie ma to żadnego wpływu

Share this post


Link to post
Share on other sites

Jeśli chodzi o linuksa, to ES100 jest jakiś nietypowy :(

Twój przypadek przypomina nieco zmuszenie go do współpracy z mpd (oczywiście w trybie wyłączności)


Podłączony jako jedyne urządzenie audio, nie działa na:
device            "hw:0,0"

nie działa również przy:
device            "default:CARD=DAC,DEV=0

Dźwięk odtwarza tylko przy automagicznym wyszukiwaniu urządzeń przez mpd, ale wtedy nie działa parametr:
auto_resample        "no"

co oczywiście skutkuje standardowym resamplingiem alsy i w efekcie wszystko leci na:
$ cat /proc/asound/card*/pcm*p/sub*/hw_params
access: MMAP_INTERLEAVED
format: S16_LE
subformat: STD
channels: 2
rate: 48000 (48000/1)
period_size: 1024
buffer_size: 16384

 

I wcale nie pomaga tutaj świadomość umieszczenia w .acoundrc:

defaults.pcm.rate_converter "speexrate_medium"

 

Po prostu nie tak to powinno działać :(

 

 

A wracając do twojego problemu ;)

Wydaje się, że warto byłoby wyłącznyć PulseAudio i pozostając tylko na alsie, zobaczyć jak się sprawy mają.

 

  • Like 1

Share this post


Link to post
Share on other sites
Jeśli chodzi o linuksa, to ES100 jest jakiś nietypowy
Twój przypadek przypomina nieco zmuszenie go do współpracy z mpd (oczywiście w trybie wyłączności)

Podłączony jako jedyne urządzenie audio, nie działa na:
device            "hw:0,0"
nie działa również przy:
device            "default:CARD=DAC,DEV=0
Dźwięk odtwarza tylko przy automagicznym wyszukiwaniu urządzeń przez mpd, ale wtedy nie działa parametr:
auto_resample        "no"
co oczywiście skutkuje standardowym resamplingiem alsy i w efekcie wszystko leci na:
$ cat /proc/asound/card*/pcm*p/sub*/hw_params
access: MMAP_INTERLEAVED
format: S16_LE
subformat: STD
channels: 2
rate: 48000 (48000/1)
period_size: 1024
buffer_size: 16384
 
I wcale nie pomaga tutaj świadomość umieszczenia w .acoundrc:
defaults.pcm.rate_converter "speexrate_medium"
 
Po prostu nie tak to powinno działać
 
 
A wracając do twojego problemu
Wydaje się, że warto byłoby wyłącznyć PulseAudio i pozostając tylko na alsie, zobaczyć jak się sprawy mają.
 

Wyłączyć tzn odinstalować?


Wysłane z iPad za pomocą Tapatalk

Share this post


Link to post
Share on other sites

Nie korzystałem nigdy z ubuntu, ale prawdopodobnie (z uwagi na rozbudowane zależności) pulseaudio stawia duży opór przy próbie odinstalowania. 
Na szczęście nie ma potrzeby usuwania go z systemu.

Zablokuj/wyłącz/zdezaktywuj -->
https://askubuntu.com/questions/1071532/systemd-disable-pulseaudio-system-mode

 

Reboot systemu i sprawdż, czy rzeczywiście pulseaudio jest wyłączone:

$ ps -e | grep pulse 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Inszy
      Firma Radsone nie ma nadzwyczaj bogatej palety produktów, jednak dostępny w Polsce adapter Bluetooth ES100 zdążył zdobyć uznanie jako jedno z najlepszych urządzeń w swojej klasie. Teraz w nasze ręce trafiły słuchawki dokanałowe o nazwie Earstudio HE100, wycenione na niespełna 90 dolarów.
      Nie jest to jednak do końca autorski projekt Radsone – to słuchawki Sonicasta, będące rozwinięciem modelu Dirac MK2, z nieco zmienionym strojeniem, by słuchawki jeszcze lepiej współgrały właśnie z adapterem ES100. Tylko czy te teoretycznie niewielkie zmiany są warte już wcale nie tak małej dopłaty w stosunku do Sonicastów?
       
      O tym i innych rzeczach związanych z He100, można poczytać pod poniższym linkiem  
      https://kropka.audio/test/sluchawki/radsone-earstudio-he100-recenzja/
       

×
×
  • Create New...

Important Information

Register to have access to community resources. Forum rules Terms of Use and privacy anc cookies policy Privacy Policy